Maptech Support
Support Home > The CAPN > Forums > The CAPN > The CAPN: Application Discussion - Version 8.0 or later > Create A Route/Runtime Error 7 and no Rightmouse click

The CAPN: General Discussion: The CAPN: Application Discussion - Version 8.0 or later: Create A Route/Runtime Error 7 and no Rightmouse click

      Mike Neumann
Original Message
(Posted Nov 3, 2006 11:47 AM)

The CAPN, Version 7.4.9, had been running great on my XP/Toshiba Laptop for the past two years when out of nowhere it became impossible to create a route or modify marks.

When you click on the drop down menu for Routes and select Create a Route, you get a dialog box that says 'Runtime Error 7 Out of Memory'. Clicking on Okay for this dialog box makes the CAPN close. When you right click the mouse on a chart hoping to have a pop-up menu that will let you create a route, you get absolutely no response. If you right click on an existing route, waypoint or mark you do not get any pop-up menus; you get absolutely no response.

To resolve the problem, I was asked by Tech Support to download and upgrade to Version 7.5 as this was the earliest version still supported. I did, using Custom Uninstall process for the old version and found I had the same problem. I was then asked to Custom Uninstall this version and download and install Version 8.3. This was done, I talked my way past the new registration agent successfully and the problem persisted. Tech Support then mailed me a disk for Version 8.3 which I installed and found the problem is still there.

I'm tired of wasting my cellphone minutes and paying long distance fees to wait in the Tech Support queque and get noone who seems to have any idea of what is happening.

Any thoughts by anyone...since Runtime Errors, when Goggled, appear to be operating system related, do I need to reinstall Windows XP and then try, hoping I can get a new registration code for this product? Is there some other way to access the lost features I have not tried?

Replies 1 - 5 of 5

     Sort( By Date - Threaded )

      Ed Lecuyer
CAPN and Runtime Errors
(msg #1: Posted Nov 3, 2006 1:45 PM)

Hi Mike,

First off, I apologize for any waits you may have had with the Tech Support Queue - we're going through a staffing change and will be adding additional reps in the coming weeks. However, it is unusual to have to wait more than a minute to speak with us; in fact, as I type this we have open phone lines.

What we have determined when the CAPN crashes inexplicably, it is usually due to one of the following reasons:

1. An bug in a older version of The CAPN that has since been corrected.
This is the case 80% (or more) of the time. Thus, the suggestions to try 7.5 and then 8.3. In fact, we will be happy to unlock version 8.3 for ANY customer who has a problem that it may correct.

2. A problem with corrupted routes, waypoints, or other data.
This is why a Custom Uninstall is an important thing to try. A Custom Uninstall removes all data - which leaves everything "clean" and without corruption.

3. A problem with bad, outdated, or incompatible charts.
This is one area you may want to try. Delete any and all charts from your HD and try the CAPN. If it works correctly, the problem is somewhere with the charts.

As an aside, we are about to release a new chart library that is specially designed for use with The CAPN. The library will include the latest CAPN software along with 18 DVDs of Raster, Vector, Photo, and 3D charts for all US waters. The upgrade price will be $149.00 - an incredible bargain. We're doing this so that all of the loyal CAPN customers can receive the latest software and charts - which will hopefully correct many of the various difficulties that have transpired in the months leading to (and immediately following) the sale of The CAPN from SAIC to Maptech in May, 2006.

4. Windows Compatibility Problems
It is possible that the errors you are experiencing are due to some compatibility problem with Windows. Thus, I recommend the following updates:

a. Obtain the latest Video Display Driver for your computer or video card manufacturer. Visit the web site of your computer manufacturer to download and install the latest video display driver. The CAPN is very dependant on this driver and it is not uncommon for updated drivers to correct these sorts of issues.

b. Obtain the latest "DirectX" from Microsoft.com.
Like the Video Driver, Microsoft is constantly making improvements and repairs to the component of Windows that handles video display. This component is known as "Direct X" and updates are available from Microsoft.com

Give these ideas a try, and if they don't work - reinstalling Windows could certainly remain an option. However that is a major undertaking unless it is really required. If you do go down that road, we'll be happy to re-register your copy of The CAPN - given your situation and history.

Please let me know if I can be of assistance in any way.

-Ed Lecuyer
Senior Customer Support Manager


      Mike Neumann
RE: CAPN and Runtime Errors
(msg #1.1: Posted Nov 4, 2006 9:26 AM)


With regards to your #3, I am experiencing no problems with the charts when using Voyager Classic. Wouldn't this mean that chart compatibility is not a problem?

Reloading all the charts is a big job too so I'll move on to #4 solutions while I await a response to the above thought.



      Ed Lecuyer
Chart Problems
(msg #1.1.1: Posted Nov 6, 2006 10:39 AM)

Hi Mike,

The chart display engine between CAPN Voyager Classic and the 8.3 version is radically different. This was done to allow for vector charts and the seamless stitching of raster charts together. For example, Maptech PCX charts are compatible with Classic, but not with the newer 8.3 release. Thus, it is conceivable that a chart problem could be the source of the errors you are receiving.

-Ed Lecuyer
Senior Customer Support Manager


      Mike Neumann
RE: Chart Problems
(msg # Posted Nov 22, 2006 1:46 PM)

The following steps were taken in the order outlined and the results toward solving this problem are outlined below.

All charts were deleted, 8.3 was 'custom' uninstalled so any startup disk charts should not appear and then 8.3 was re-installed. The program continued to have no response to right mouse clicks and crashed when create a route was selected from the pull down menu.

The Toshiba website was visited and the Video display driver was downloaded and installed over the original driver. Program difficulties continued.

The DirectX was updated from the Microsoft website. Program difficulties continued.

The hard drive was reformatted and Windows XP was reinstalled (what a time consuming process that is!). The Video display driver was updated from the Toshiba website and 8.3 was reinstalled. Everything worked...hooray! All the other applications were reloaded to the hard drive and after each installation, 8.3 was checked for problems. None were found.

I called and got a new registration key. Everything is working okay at this point. Guess I can go cruising again.

Thanks for the input.


      Ed Lecuyer
(msg # Posted Nov 22, 2006 2:51 PM)

Glad to know that you are back up and running. Please let us know if we can provide any additional assistance.

-Ed Lecuyer
Senior Customer Support Manager


Replies 1 - 5 of 5


© 1989 - 2015 Maptech, Inc., All Rights Reserved. Maptech ® is a registered trademark of Maptech, Inc.