Maptech Support

The CAPN: General Discussion: The CAPN: Application Discussion - Version 8.0 or later: "Run Time Error 5" Message and Capn Lock-up

      Dave Acton
Original Message
(Posted May 7, 2007 9:40 AM)

I run the latest (March) version and charts on a Dell laptop running XP with the latest updates. No other applications are running. When cruising this weekend Capn locked-up and displayed the following error message: "Run time error "5". Invalid procedure call or arguement." When I click to acknowledge the error, the message disappears and the Capn shuts down. When I restart Capn (no reboot) it comes right up. It then goes down again with the same error in another 20+ minutes.

Any idea what's going on here?

Replies 5 - 14 of 14

     Sort( By Date - Threaded )

      jim monahan
RE(5): Reply from Maptech
(msg # Posted May 30, 2007 9:22 AM)

I have experienced the same problem. I am running a gateway pentium 4, 1.7 g with 500 mb memory. I have just reformatted the drive and reinstalled windows, the Capn, and the new vector charts. I don't run any other programs on this computer. I will report it there is any change.


      Wayne Pearson
RE(6): Reply from Maptech
(msg # Posted May 30, 2007 11:04 AM)


Reinstalling The Capn would be a good idea here.
Make sure to export any important marks and routes first.
Then, do a Custom uninstall before you reinstall in The Capn; a Custom uninstall will remove the little files The Capn creates more completely than the default Automatic uninstall.

A shaky GPS connection is definitely a possible cause of your error in The Capn. The NMEA sentences sent by your GPS need to be a constant, correct, and uninterrupted data stream. A shaky connection could result in fragmented NMEA sentences.

Wayne Pearson


      michael bogannam
RE(7): Reply from Maptech
(msg # Posted Jun 12, 2007 12:00 PM)

Hi Dave,

I just recently helped another user out with this ame issue.
He was getting the same "Runtime Error 5" - invalid argument.

The fix for him was double checking the wiring of his NMEA instruments that were being fed into the computer (and Capn) via a miniplexer. He had incorrectly had wired the miniplex. The old wiring was IN+ and OUT+ . It should have been to TLK+. This had
stopped the multiplexer from reporting errors.
After that we discovered that the baud rate of the miniplex was set to 4800, changing that to 9600 (coupled with the re-wiring) eliminated the RunTime Error 5.

Does any of this compare to your situation?

-Michael Bogannam
Technical Support Rep.


      Dave Acton
RE(8): Reply from Maptech
(msg # Posted Jun 13, 2007 8:30 AM)

I’m using a JRC DGPS that was originally wired to supply nema data (time,lat, long, waypoints, etc) to the JRC radar display. When I bought the boat, I wired a serial cable into this feed to send nema to my laptop. I’m not using any kind of gps multiplexor. This worked well for two years – no issues at all.

Problems started this spring – the same time I started using the March release of 8.3 and the new charts. But I at the same time period noticed that I’m getting a new, intermittent (but fairly frequent) loss of nema data to the radar display (the beep is driving me crazy). CAPN does not report a loss of gps in nearly all of the cases the radar alarms, but has noted the loss once or twice in a 2-3 hour period. Perhaps the loss of signal is so quick that it doesn’t effect CAPN, but at some point the rapid on/off of the nema data causes the run time error?

Because this is affecting both systems, I’m going to get to the gps feed this weekend and check for a bad connection. I’m running on a trip the following week and will get to test to see if the problem goes away. I’ll let you know how I make out.



      michael bogannam
RE(9): Reply from Maptech
(msg # Posted Jun 13, 2007 9:46 AM)

Other than position, what kind of NMEA data are you trying bring into the Capn?
(ie, wind, depth...)

What I had to do with last situation like this was to remove all incoming devices and add them back in one at a time.
Can you connect the GPS to the laptop for now and bybass all the other variables, just as a test?

-Michael Bogannam
Technical Support Rep.


      Dave Acton
RE(10): Reply from Maptech
(msg # Posted Jun 14, 2007 11:15 AM)

I'm only passing position data, sog, cog, etc from the gps. All other instrumentation, such as depth, is too old for nema -- interface is proprietary. I don't even have the autopilot in the loop.

I'm going to try checking all the connections first. The fact that this worked fine for two years and started at the same time as the radar glitch leads me in that direction. If that doesn't work, I may try connecting the pc directly to the gps. Since I'm not using the gps for any kind of waypoints or navigating, I really don't care whether it sends anything to the rada (except maybe heading info for true bearing, but I rely mostly on relative bearing when I'm looking at things anyway. Hopefully I'll find a bad connection and all will be well.


      michael bogannam
RE(11): Reply from Maptech
(msg # Posted Jun 18, 2007 8:07 PM)

Please keep in touch. Please let me know if you do or don't find anything.

-Michael Bogannam
Technical Support Rep.


      Dave Acton
RE(12): Reply from Maptech
(msg # Posted Jun 26, 2007 8:40 AM)

No joy. I found one screw on the terminal bus that was maybe 1/8 turn loose. It was a ground for the gps. I tightened it and then ran both the radar and the GPS for six hours at the dock -- no problem. On last week's trip, the run time error occurred again within 10 minutes of leaving the dock. I shut down the pc and used my chart plotter on the fly bridge.

I'm off the boat for the next 3 weeks. When I return I'll recheck the connections again. I'll also run with the pc out of the circuit and see if the radar still acts up. I'm guessing now that it won't, once the pc and the CAPN are out of the circuit.

Any ideas would be appreciated. I'm about ready to just get a chart plotter for my pilot house and make life a lot simpler.


      Dave Acton
RE(13): Reply from Maptech
(msg # Posted Aug 20, 2007 1:20 PM)

I just completed a one week trip with no problems...I used an independent GPS (handheld) with my laptop and CAPN. So, looks like no problem with CAPN or the laptop.

It's back to looking for a problem with the installed GPS wiring to the radar and the laptop. It just uses a normal terminal block in two places to link the two. It worked fine for two years. Would I benefit from looking at a gps multiplexer...could using a terminal block be the problem? What benefits are gained from a multiplexer? What one sold by Maptech (Capn Jack) would be a good solution for my "one talker - two listener" set up?


      michael bogannam
RE(14): Reply from Maptech
(msg # Posted Aug 20, 2007 2:38 PM)

Hi Dave,

What I suggest that you use to replace the terminal block is the MiniPlex-Lite Multiplexer.

The big advantages of the Mutilpex-Lite over a terminal bock is that
A) the Terminal Block is not going to spilt the signal, there is no Talker on the terminal block.
B) If your inputs are running at different baud rates, or when you get into using AIS with the Capn, the Miniplex-Lite will adjust for this and you do not need to use multiple COM ports to take this into consideration.
C) Very simple USB connectivity to the computer.

I have taken the liberty in emailing you a PDF manual for the Miniplex-Lite for further understanding and to get a better idea how this will work.

Also, just to make sure, I wanted to mention that the Capn was updated again recently.
Please click here to download the v8.3.20 update.

-Michael Bogannam
Technical Support Rep.


Replies 5 - 14 of 14


© 1989 - 2015 Maptech, Inc., All Rights Reserved. Maptech ® is a registered trademark of Maptech, Inc.