HOME > SUPPORT > FORUMSLog In
Maptech Support




The CAPN: General Discussion: The CAPN: Application Discussion - Version 8.0 or later: "Run Time Error 5" Message and Capn Lock-up








      Dave Acton
Original Message
(Posted May 7, 2007 9:40 AM)
reply


   
I run the latest (March) version and charts on a Dell laptop running XP with the latest updates. No other applications are running. When cruising this weekend Capn locked-up and displayed the following error message: "Run time error "5". Invalid procedure call or arguement." When I click to acknowledge the error, the message disappears and the Capn shuts down. When I restart Capn (no reboot) it comes right up. It then goes down again with the same error in another 20+ minutes.

Any idea what's going on here?








     Previous     
Replies 1 - 10 of 14
     Next     





     Sort( By Date - Threaded )








      Dave Acton
RE: Reply from Maptech
(msg #1: Posted May 18, 2007 11:00 AM)


   
I never got a response to this on this forum. Here's the answer I got when I emailed maptech support directly. Has anyone else had a similar problem?

MY RESPONSE:
Thanks for the ideas.

The error is not related to any power drop. We were running “hot, straight, and normal”. I was navigating with the new vector charts for the first time. I had not experienced an error like this in earlier versions of the CAPN (including yours) or with my Soft Charts.

MAPTECH RESPONSE:
--------------------------------------------------------------------------------

From: Inside Sales [mailto:insidesales@maptech.com]
Sent: Friday, May 18, 2007 8:51 AM
To: David Acton
Subject: RE: CAPN Run Time Error 5

Hi,

Run time errors are hard to isolate.

Here are some ideas:

Does this error happen when you are using one specific chart?

A corrupt chart file could be corrected by deleting and then

recopying the file(s) from your CD or DVD to your hard drive.



Custom uninstall (not automatic uninstall) The Capn program

and then install The Capn program, to clear out any legacy

small files an earlier version of The Capn may have created

that were not removed or reset during the latest update.

We have found that automatic uninstall doesn't always

clear out all of the little files The Capn program creates.



Check on the internet for a more recent DirectX driver,

at http://www.microsoft.com



Check on Dell's web site for a more recent video driver.



Is the run time error coincident with a power drop on the boat?



Wayne Pearson

Tech Support



 


      Wayne Pearson
RE(2): Reply from Maptech
(msg #1.1: Posted May 24, 2007 8:25 AM)


   
Hi Dave,

It sounds like the runtime error could be coincident with your "new vector charts".

You can remove your vector charts and then reinstall them; this will solve the runtime error problem if there is a corrupt file among the vector chart files.

Assuming your hard drive is C:, the new vector charts are installed in C:\SoftSDNC and C:\SoftSENC. Using MY COMPUTER, delete these two folders. This will remove all of your vector charts.

Reinstall your vector charts using the Capn Installer disk.

Wayne Pearson


 


      Dave Acton
RE(3): Reply from Maptech
(msg #1.1.1: Posted May 24, 2007 9:56 AM)


   
Thanks!

I'll be traversing the same area this weekend and was going to use the raster charts to see if I have the same problem. I'll take my disk set down too and try a reinstall.


 


      Dave Acton
RE(4): Reply from Maptech
(msg #1.1.1.1: Posted May 29, 2007 10:15 AM)


   
I removed all vector files and reinstalled. Still had the problem. On the return trip, the problem occured with raster charts as well. I guess I'll try reinstalling the entire CAPN software next.

I did notice that I had a very shaky gps connection to my radar. The same feed goes to the laptop. Could a frequent on/off gps signal cause a problem like this? I ran the system in DR mode for a good 3 hours and had no lock up at all.


 


      jim monahan
RE(5): Reply from Maptech
(msg #1.1.1.1.1: Posted May 30, 2007 9:22 AM)


   
I have experienced the same problem. I am running a gateway pentium 4, 1.7 g with 500 mb memory. I have just reformatted the drive and reinstalled windows, the Capn, and the new vector charts. I don't run any other programs on this computer. I will report it there is any change.


 


      Wayne Pearson
RE(6): Reply from Maptech
(msg #1.1.1.1.1.1.89.463.216: Posted May 30, 2007 11:04 AM)


   
Hi,

Reinstalling The Capn would be a good idea here.
Make sure to export any important marks and routes first.
Then, do a Custom uninstall before you reinstall in The Capn; a Custom uninstall will remove the little files The Capn creates more completely than the default Automatic uninstall.

A shaky GPS connection is definitely a possible cause of your error in The Capn. The NMEA sentences sent by your GPS need to be a constant, correct, and uninterrupted data stream. A shaky connection could result in fragmented NMEA sentences.


Wayne Pearson


 


      michael bogannam
RE(7): Reply from Maptech
(msg #1.1.1.1.1.1.89.463.216: Posted Jun 12, 2007 12:00 PM)


   
Hi Dave,

I just recently helped another user out with this ame issue.
He was getting the same "Runtime Error 5" - invalid argument.

The fix for him was double checking the wiring of his NMEA instruments that were being fed into the computer (and Capn) via a miniplexer. He had incorrectly had wired the miniplex. The old wiring was IN+ and OUT+ . It should have been to TLK+. This had
stopped the multiplexer from reporting errors.
After that we discovered that the baud rate of the miniplex was set to 4800, changing that to 9600 (coupled with the re-wiring) eliminated the RunTime Error 5.

Does any of this compare to your situation?

-Michael Bogannam
Technical Support Rep.


 


      Dave Acton
RE(8): Reply from Maptech
(msg #1.1.1.1.1.1.89.463.216: Posted Jun 13, 2007 8:30 AM)


   
I’m using a JRC DGPS that was originally wired to supply nema data (time,lat, long, waypoints, etc) to the JRC radar display. When I bought the boat, I wired a serial cable into this feed to send nema to my laptop. I’m not using any kind of gps multiplexor. This worked well for two years – no issues at all.

Problems started this spring – the same time I started using the March release of 8.3 and the new charts. But I at the same time period noticed that I’m getting a new, intermittent (but fairly frequent) loss of nema data to the radar display (the beep is driving me crazy). CAPN does not report a loss of gps in nearly all of the cases the radar alarms, but has noted the loss once or twice in a 2-3 hour period. Perhaps the loss of signal is so quick that it doesn’t effect CAPN, but at some point the rapid on/off of the nema data causes the run time error?

Because this is affecting both systems, I’m going to get to the gps feed this weekend and check for a bad connection. I’m running on a trip the following week and will get to test to see if the problem goes away. I’ll let you know how I make out.



DHA



 


      michael bogannam
RE(9): Reply from Maptech
(msg #1.1.1.1.1.1.89.463.216: Posted Jun 13, 2007 9:46 AM)


   
Other than position, what kind of NMEA data are you trying bring into the Capn?
(ie, wind, depth...)

What I had to do with last situation like this was to remove all incoming devices and add them back in one at a time.
Can you connect the GPS to the laptop for now and bybass all the other variables, just as a test?


-Michael Bogannam
Technical Support Rep.


 


      Dave Acton
RE(10): Reply from Maptech
(msg #1.1.1.1.1.1.89.463.216: Posted Jun 14, 2007 11:15 AM)


   
I'm only passing position data, sog, cog, etc from the gps. All other instrumentation, such as depth, is too old for nema -- interface is proprietary. I don't even have the autopilot in the loop.

I'm going to try checking all the connections first. The fact that this worked fine for two years and started at the same time as the radar glitch leads me in that direction. If that doesn't work, I may try connecting the pc directly to the gps. Since I'm not using the gps for any kind of waypoints or navigating, I really don't care whether it sends anything to the rada (except maybe heading info for true bearing, but I rely mostly on relative bearing when I'm looking at things anyway. Hopefully I'll find a bad connection and all will be well.


 








     Previous     
Replies 1 - 10 of 14
     Next       













 


© 1989 - 2014 Maptech, Inc., All Rights Reserved. Maptech ® is a registered trademark of Maptech, Inc.

TERMS AND CONDITIONS